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File Menu

The File Menu enables you to work with data files through actions that manipulate the flle as 
a whole.    The commands which can be selected from the File Menu are (click on command 
for more information):

New
Open
Save
Save As
Convert File
Print
Review Changes Command
Exit



New Command

The New command allows you to create a new file which will become the active file.    It is 
recommended that you name your primary data file "VCATDATA.DAT".    It is also 
recommended that all data files have the ".DAT" suffix.



Open Command

The Open command reads an existing file and displays it for manipulation.    The initial 
template for data files is ".DAT".    You can change it to list choices with other suffixes, but it 
is recommended that you use a ".DAT" suffix in naming all data files.    

A list box displays files in the current directory matching the template as well as other drives
and subdirectories.    Controls are also available to change drive and directory.    Clicking on a
file once displays it in the filename window, which can be selected by clicking "OK".    Double
clicking on a listed file selects it immediately.

The program performs a rather simplistic test to try to detect whether the selected file is a 
valid Videocat data file and will refuse to open a file which appears invalid.    This test is not 
foolproof.    Do not attempt to open files which you know are not Videocat data files.

Although the Open dialog permits you to navigate throughout the various disks and 
directories in your system, it is recommended that you keep your data files in the same 
subdirectory as VCW.EXE.



Save Command

The Save command updates the currently active file with pending change transactions and 
writes it to disk.    The file remains the active file, but will now reflect changes which have 
been processed.    

The action of the Save command is identical to that of the Update command which was used
in some prior versions of Videocat.
Videocat uses a batch file update.    The additions, changes and deletions you make will not 
appear in either the data file or the display until you execute either the Save command or 
the Update command.



Save As Command

The Save As command merges pending changes with the current file content and writes the 
result to a different file, leaving the current file unchanged.



Print Command

The Print command prepares the currently displayed file (which may be either a regular data
file, a sorted data file, or a search data file) for printing and prints it on the printer.    

The dialog box which is displayed will also give you the option to change the printer which 
will be used.



Convert File Command

The Convert File command permits you to convert files created under older versions of 
Videocat so that they can be used with the current version.

Files created under Versions 7.0 or 7.1 , or in the standard (non-windows) edition of Version 
7.2, are always named VCATDATA.DAT,    and can be used without change in the current 
version.    Files created under version 7.2W (Windows edition) may have a user-assigned 
name and can also be used without change in the current version.

Files created under any version in the 5.x or 6.x series are named BASEFIL5.DAT and require 
conversion before they can be used in the current version.

Files created under any version in the 4.x series are named BASEFILE.DAT and require 
conversion before they can be used in the current version.

No provision is made for conversion of files created under versions prior to 4.0 as these 
versions were not placed in public distribution.

The convert file command will prompt you to select the file you wish to convert.    It can be 
located in any drive or directory.    The program will then perform a somewhat simplistic 
validitiy check to determine whether the file you have selected appears to be a valid prior-
version Videocat file.    If this validity check is passed, the program will prompt you to enter 
the name of the new file which    you wish the conversion routine to create.    If this is to be 
your main data file, it is recommended that you use the name VCATDATA.DAT.    If you use 
another name, it is still recommended that the extension be ".DAT".

The converted file will contain all of the data which was in the old file in the curent format.    
Those data fields which were not used in prior versions will simply be blank in the new 
records.    You can select a record and edit it to fill in the blank fields if you wish.



Exit Command

The Exit command ends the Videocat application and removes its window from the screen.    
If you have pending changes awaiting update, the program will ask if you want to save 
them.



Add Menu

The Addmenu contains one command to add a new record to the current data file:

Add Command



Add Command

The Add command is used to create a new record for addition to the file.    This command 
invokes a dialog box which displays a blank record and permits you to enter data in the 
various fields.    The Add command does not affect the currently selected record.

It should be noted that Videocat uses a batch file update approach, so additions, changes 
and deletions    made from the Edit Menu will not be written to disk or reflected in the 
displayed file until the Save command is executed from the File Menu.    If the Save As 
command is executed, then the changed data will be written to a different file, leaving the 
currently active file unchanged.    To see what pending transactions are awaiting update, use 
the Review command.



Review Command

The Review command invokes a dialog box with a list of transactions awaiting update.    A 
pending transaction can be deleted from the list by clicking it with the mouse.

Transactions are identified as being adds or deletes.    The Change command generates two 
transactions: a delete for the original record and an add to replace it with the changed 
version.    To undo a Change it is necessary to correctly identify the related add and delete 
pair and remove them both from the list of pending transactions.



View Menu

The View menu contains commands that enable you to select different ways of looking at 
the content of the active data file without affecting the file itself.    The commands available 
from the View menu include (click on command for more information):

Title Order Command
Location Order Command
Year Order Command
Search Command
New Records Command



Title Order Command

The Title Order Command command causes all records to be displayed in title order (the 
default order).    



Location Order Command

The Location Order Command command causes all records to be displayed in title location 
order (by cassette and index number).    



Year Order Command

The Year Order Command command causes all records to be displayed in year of production 
order.    



Search Command

The Search command causes only those records having certain data values to be displayed.  
A dialog box is invoked which permits you to select the key values for the search and 
whether long or short display format should be used.    If the search selects multiple records, 
they are displayed in title order.

Multiple search keys can be selected.    Multiple keys are considered conjunctive, i.e. a record
must meet all of the search criteria in order to be displayed.

When title or comments are selected as search keys, the search text is treated as a 
substring, i.e. a record will be selected if the search text matches any part of the text within 
the record field.    When searching by title, it is recommended that you use only as much of 
the title as you are sure of to reduce the difficulty of getting an exact match.



New Records Command

The New Records Command causes all records to be displayed which were created or 
modified on or after a specified date.

This is particularly useful for printing a catalog supplement to show recent additions when 
you do not want to reprint your entire catalog.

Note that prior to Version 7.2 the program did not include date stamp information on data 
records, so you may find that some of your older records are ignored by this command.    



Options Menu

The Options menu contains commands that permit you to customize the way in which the 
program works.    The available commands are:

Customize Descriptions Commands

Click on command for more information.



Customize Descriptions Commands

The Cusomize Descriptions commands enable you to change the text descriptions 
associated with many of the category codes used in data records.

You may find this useful if you have a specialized collection (e.g. all educational or all adult) 
and want to custom design a set of Subject and Form descriptions.    If you live outside the 
United States you may wish to change the MPAA Code and Rating descriptions to 
comparable systems in use in your country.    If you are using new types of audio and video 
equipment which are not reflected in the standard descriptions you may wish to change the 
Format, Color or Sound descriptions.

Note that each of these fields is represented by a single character code in the data record.    
Customizing descriptions does not change the records; it changes the way in which the 
existing codes are translated when records are displayed.    It is recommended that you plan 
your custom classification system carefully before using the Customize Descriptions feature. 
Frequent    or casual changes can introduce hopeless confusion.

Customized descriptions are stored in special files which have the ".CFG" extension.    If you 
transfer the program (VCW.EXE) to a different directory or computer, be sure you also 
transfer the .CFG files if you want to continue to use your customized descriptions. 



Help Menu

The Help menu enables you to access a variety of help information.    The commands 
available from this menu are:

Help Index
Using Help
About
Registration Info



Help Index Command

The Help Index command invokes the Videocat Help System and displays a list of the major 
topic indexes available.    Clicking on one of the indexes in this list will cause a detailed index
to be displayed, from which particular help topics can be selected.

Note that the file VCW.HLP must be present in in the same directory as VCW.EXE in order to 
use the Videocat Help system.



Using Help Command

The Using Help command invokes the Windows Help System, which provides information on 
how to use Help.



About Command

The About command invokes a dialog box which display the program name, version number 
and copyright notice.



Registration Info Command

The Registration Info command displays a dialog box with brief information on how to 
become a registered user.



Labels Menu

The Labels Menu menu contains one command to generate labels:

Labels Command



Labels Command

The Labels command provides a specialized facility to print labels for videocassettes.

The Labels function requires that the data file be sorted in cassette number order.    If the 
currently displayed file is not so sorted, the program will ask for permission to do so.

The dialog box for Labels will give you the opportunity to select and configure the printer to 
be used.    You will also be given a list of several choices of label stocks.    Label stocks are 
described as either "continuous feed" or "laser sheet".    

Continuous feed labels come in a long strip intended for pin or tractor feed through a 
standard printer; you should position the label stock so that the first position struck by the 
print head will be just within the upper left corner of a label.    Note that since Videocat for 
Windows uses the Windows print manager, it only supports those continuous feed labels 
which are spaced at 1-inch intervals (VHS and Beta Spine labels) and fit evenly within an 
11=inch "page".        

Laser sheet labels are single sheets of peel-off labels designed for laser printers.    The 
program uses the Windows print manager to figure out where to position printing when you 
have a laser printer installed in Windows.    You may be able to use laser sheets in a standard
printer, but you will have to determine by experimentation how to position the label sheet 
relative to the print head so that the printing will fall within the labels.

Caution:    Before printing labels in a laser printer, be sure to consult your owner's manual 
and follow all steps prescribed.    For example, Hewlett-Packard recommends that you open 
the back "Face-Up" door to minimize paper jams and internal wear when printing labels.

If you find that local retailers do not stock video labels, you may wish to contact one of the 
following mail order vendors:

Virginia Specialty Products
P.O. Box 985
Vienna, Virginia 22180
Telephone: (703) 280-1742

United Ad Label Company
650 Columbia Street
P.O. Box 2216
Brea, California 92622
Telephone: (800) 423-4643
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Title Description

The title field of the data record is intended to hold the title of an individual movie or other 
item in your collection.    Title is the primary key by which records are identified and sorted.    
You could leave this field blank, but it doesn't make much sense to do so.

The maximum length of the title field is 40 characters.    The program will not permit you to 
enter more.    If you want to record more title information than will fit, you can use the 
Comments field.    

It is suggested that the words "A", "An", or "The" at the beginning of a title be appended to 
the rear after a comma.    For example, instead of entering "The Bridge on the River 
Kwai", enter "Bridge on the River Kwai, The".    This keeps the alphabetical sequence of 
titles a little more meaningful.

For episodes in a series, it is suggested that the series title be entered first, then the episode
title.    For example: "Star Trek: Gamesters of Triskelion" and "Star Trek: Spock's 
Brain".

Note that since the program sorts the titles in ASCII (American Standard Code for 
Information Interchange) sequence, titles beginning with numeric characters or punctuation 
characters will come before titles beginning with alphabetic characters.    Thus the movie 
"1941" will be placed near the beginning of the catalog before titles beginning with 
alphabetical characters and not in the N's as is common in the organization of published 
movie guides.

More than one record can have the same title (thus allowing for remakes), but the program 
will not permit two records to have both the exact same title and year of release.    Minor 
variations in title will allow cataloging of several versions of the same film.    For example:    
"Topper" and "Topper [colorized]"; "A Star is Born [edited for TV]" and "A Star is 
Born [uncut]"; "Citizen Kane [copy 1]" and "Citizen Kane [copy 2]".    Likewise you can 
indicate when a title continues over more than one cassette: "Gone With the Wind [part 
1 of 2]" and "Gone With the Wind [part 2 of 2]".

The title field can also be used to keep track of blank tape segments.    For example, if you 
decide that "Porky's" isn't worth keeping, just use the Change command to change the title 
field to read "BLANK Porky's".    You can then use the Search command to find all records 
that have the word "BLANK" in the title field to find space available for re-recording.    If you 
then decide to record over "BLANK Porky's", click that record with the left mouse button to 
make it the selected record and use the Change command again to enter the new title and 
other changed information.

 



Year Description

The year data field is intended to hold the year of release of a production, normally 
expressed as 4 numeric characters, e.g. "1939".    

The program treats the year as a four-byte character string, so non-numeric characters will 
not    be rejected.

Year is the secondary key by which records are sorted when the data file is constructed.    If 
two records have the same title the one with the earlier year will appear first.    It is also 
possible for you to request that the file be displayed in year order when you use the Whole 
Catalog command in the View menu.    

Although you do not have to enter a year, it is recommended that you do so in every record. 
If you are not sure, look up the year in a movie guide or make a reasonable guess.



Actors Description

The record format includes three data fields intended to record the names of actors.

The use of the actor name fields is optional; it does no harm to leave any or all of them 
blank.    All three of these fields will be checked when you use the Actor option in the Search 
command.

When you are asked to enter an actor name a dialog box will appear with separate edit fields
for last name and first name.    In filling the last name field enter the actor's last name, 
including prefixes and suffixes which are properly part of the last name.    For example: "von 
Stroheim" and "Fairbanks, Jr.".    In that last example the program will replace the comma 
and space with a single space, turning it into "Fairbanks Jr.".    This is necessary because 
the comma character is the delimiter which separates the first and last names in the way 
names are stored by the program.    Comma deletion was added in Version 7.03; if you have 
a data file created under prior versions you may find that names which include commas are 
somewhat garbled.    You can use the Change command to clean them up.

In the first name edit field you should enter any initials or middle names which are regularly
used by the actor in billing.    For example: "George C." and "Leslie Ann".

Try to be consistent in the way you enter names.    The Search command looks for exact 
matches when it searches by name.    Different spellings will be regarded as different names.

The maximum combined length of the first and last names is 30 characters; any excess will
be truncated from the first name.



Director Description

The record format includes one data field intended to record the name of the director.

The use of the director name field is optional; it does no harm to leave it blank.    This field 
will be checked when you use the Director option in the Search command.

When you are asked to enter an director name a dialog box will appear with separate edit 
fields for last name and first name.    In filling the last name field enter the director's last 
name, including prefixes and suffixes which are properly part of the last name.    For 
example: "von Stroheim" and "Fairbanks, Jr.".    In that last example the program will 
replace the comma and space with a single space, turning it into "Fairbanks Jr.".    This is 
necessary because the comma character is the delimiter which separates the first and last 
names in the way names are stored by the program.    Comma deletion was added in Version
7.03; if you have a data file created under prior versions you may find that names which 
include commas are somewhat garbled.    You can use the Change command to clean them 
up.

In the first name edit field you should enter any initials or middle names which are regularly
used by the director in billing.    For example: "George C." and "Leslie Ann".

Try to be consistent in the way you enter names.    The Search command looks for exact 
matches when it searches by name.    Different spellings will be regarded as different names.

The maximum combined length of the first and last names is 30 characters; any excess will
be truncated from the first name.



Subject Description

The Subject field holds a code for the first of two words which describe the genre of the film 
( western, musical, etc).    The other is Form.

When the Subject is to be selected, a list of 42 enumerated subject categories will be 
displayed.    Click on the button for the one which is most appropriate.    This entry is optional
and leaving it blank will do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Form Description

The Form field holds a code for the second of two words which describe the genre of the film
(comedy, drama, etc.).    The other is Subject.

When the Form is to be selected, a list of 24 enumerated form categories will be displayed.    
Click on the button for the one which is most appropriate.    This entry is optional and leaving
it blank will    do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



MPAA Code Description

The MPAA Code field holds a code for an audience suitability rating (G, PG, R, etc.).    When 
the MPAA Code is to be entered a list of the rating codes of the Motion Picture Association of 
America will be displayed.    Select either the one actually assigned by the MPAA or a 
different code if you would rate it differently.    This entry is optional and leaving it blank will 
do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Rating Description

The Rating field holds a code for rating the general quality of the movie (Excellent, Very 
Good, etc.).    When the quality rating is to be entered a list wll be displayed presenting 8 
enumerated rating descriptions.    The system used is one which is widely used in movie 
guides and TV schedules.    Whether you rate a movie based on your personal opinion or that
of professional critics is up to you.    This entry is optional.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Color Description

The Color description field holds a code indicating the color type of the movie or recording.    
The choices displayed include color, black and white, colorized, etc.    This entry is optional 
and leaving it blank will do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Sound Description

The Sound description field holds a code indicating the sound type of the movie or recording 
(stereo, mono, etc.).    This entry is optional and leaving it blank will do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Format Description

The Format description field holds a code indicating the format of the film or recording (VHS,
Beta, Laser Disk, etc.).    This entry is optional and leaving it blank will do no harm.

If you do not find that the categories presented are suitable for your needs, you can change 
the descriptive words by using the Customize Descriptions command in the Options Menu.



Minutes Length Description

The Minutes Length field    is    a text field which will permit entry of up to three characters.    
It is intended that numeric characters representing the running time in minutes be entered, 
e.g. "120" for a two-hour recording.    The program will not, however, reject non-numeric 
characters.

There is no provision for customization of this feature.



Cassette Number Description

The Cassette Number field is a text field which will permit entry of up to four characters, e.g.
"1253", representing the number of the cassette, reel or disk in your collection.    It is 
recommended that you use numeric characters only.    If you include non-numeric characters 
you may cause unintended effects on the range selection feature of the Labels printing 
function.

Although it is possible to omit this entry, Cassette Number is one of the most significant 
items of data in cataloging a large collection.    It is essential for the proper operation of the 
location sequence option of the Whole Catalog of the View menu.    Cassette Number is the 
primary key for sorting the data file into location sequence.    The secondary key is Index 
Number.



Index Number Description

The Index Number field is a text field which will permit entry of up to four characters, e.g. 
"4678", representing either the tape counter location of a particular catalog item on a 
cassette which contains multiple items.    If you do not keep track of tape counter locations, 
you can simply use a sequence number, i.e. "1" for the first item on the tape, "2" for the 
second item, and so forth. 

Although it is possible to omit this entry, Index Number is a very useful piece of data in 
cataloging a large collection.    It is useful essential for the proper operation of the location 
sequence option of the Whole Catalog of the View menu.    Index Number is the secondary 
key for sorting the data file into location sequence.    The primary key is Cassette Number.    
When the Lables command is used, Index Number determines the sequence in which 
multiple items will appear on a single label.



Comments Description

The Comments field permits you to enter free-form text comments in a record.    This field 
can be used to store any other data (e.g. Oscars and other awards, a short plot summary, 
additional credits, or any other information you might want to store in the record.    Since you
can use the Search command to search for records with particular words in the comment 
field, this is an easy way to add new kinds of search keys, such as names of script writers, 
musical score coposers, production studios, etc.

When you choose to enter comments a small text editor window will appear with room for 
three lines of 60 characters each.    The cursor can be moved using the arrow keys, Home 
and End.    Text can be deleted using the Delete or Backspace keys.    In order to maintain 
compatibility with the standard version of Videocat, the text in the edit field is in fixed width 
spacing, so it will look a little different than when the record is displayed in other windows 
which use variable width spacing.

The use of the Comments field is entirely optional.





How to Index
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How to Create a New File 

Select the Filet Menu and then select the New Command.



How to Open an Existing File 

Select the File Menu and then select the Open Command.



How to Save Changes to a File 

Select the File Menu and then select the Save Command.



How to Add a New Record 

Select the Add Menu and then select the Add Command.



How to Change a Record 

Select a record from the main window display    and then click on the Edit button.    Make the 
desired changes in the Edit window which will be displayed.



How to Delete a Record 

Select the desired record by clicking on it in the main window display and then click on the 
Delete button.



How to Convert an Old Videocat File 

Select the File Menu and then select the Convert File Command.



How to Customize Videocat 

Select the Options Menu and then select    one or more of the Customize Descriptions 
Commands.



How to Become a Registered User 

Select the Help Menu and then select the Registration Info Command for instructions..




